alembic util command error can’t find identifier

Исправляем ошибку alembic util command error can’t find identifier.

Такая ошибка может появится во разных случаях. В том числе, если сделан следующий коммит, но не отправлен предыдущий.

Можно попробовать удалить последний файл созданный в директории migrate по команде commit. И попробовать запустить команду flask db uprgade.

Или пойти более радикальным способом.

Стоит поискать иной способ, если не хотите кардинальных изменений, описанных ниже.

1. Удалим в SQL таблицу

DROP TABLE alembic_version;

2. Удалим в проекте директорию migrate.

3. Проделаем заново миграцию:

flask db init
flask db migrate -m "Initial migration."
flask db upgrade

На сайте отсутствует реклама! Значете почему?

Помогать людям - моё хобби. А навыки разработчика позволяют не парится нулевой монетизизацией этого сайта. Хотя...

Если вам помогла информация, то даже от доната в 40 рублей мне будет приятно. Докину немного, куплю латте в макдаке, вспомню за чей счет банкет и карма вам зачтется!

Но и просто оставленный комментарий благодарности ниже принесет мне улыбку радости :)

А если захочется написать всякие гадости с переходом на личности, да тоже не стесняйтесь, но обычно я отправляю такое в спам. Люблю, когда дома чисто.

Добавить комментарий

Напишите свой комментарий, если вам есть что добавить/поправить/спросить по теме текущей статьи:
"alembic util command error can’t find identifier"